Ericom Forums
 
 
Support Center   |    Forums   |    Blog   |    Contact

Home / Community - Forums / PowerTerm WebConnect / Signed SSL-certificate in application portal

Signed SSL-certificate in application portal

5 posts, 0 answered

By cowboy73 » 01 Jul 2014

Hello,
I have installed a SSL-certificate from a trusted CA. It works flawless in browsers for logging in to PowerTerm App portal. When clients are using InternetExplorer starting applications work allright, with other browsers (Firefox, Chrome, Opera etc) they get a warning from Java saying the certificate cant be trusted. But its showing correct certificate details...

Any way of resolving this?

 
cowboy73
3 posts
Joined: 01 Jul 2014
By Anonymous » 02 Jul 2014

Hey,

it sounds like your Downloader_Signed.jar that is located in the Web folder may be out of date. you can tell if you get security prompts when you launch the application. if you get certificate untrusted when you first hit the main portal page then its your IIS Certificate.

 
Anonymous
By James_Ericom » 02 Jul 2014 in reply to cowboy73

Internet Explorer uses ActiveX when auto-downloading and installing the native Ericom client.

All other browsers use a Java applet to download the same native client.  Here is a link to a recently signed Downloader_Signed.jar 

http://www.ericom.com/PowerTermWebConnectJavaDownloaderFix.asp

Please back up your existing file, copy the updated one into the same location, and try the download again.  If you encounter any issues, please contact your local Ericom support office.


 
James_Ericom
Top Contributor 66 posts
Joined: 02 Apr 2014
By Anonymous » 02 Jul 2014

Have already tried that .jar-file, same result. Its not a problem with IIS/secure gateway, as i get secure connection when logging into the portal. But java isnt accepting the certificate, or so it seems.

 
Anonymous
By James_Ericom » 08 Jul 2014 in reply to Anonymous

Hi,

Can you install the client via MSI for now.  Also, verify that the date on the system is correct and that you have the latest Java installed.

It's probably best if you contact your local Ericom support team at this point for direct troubleshooting.  We will need to understand the issue directly on the affected system as this is not a common issue.

You may also test with our demo site to see if this site has the same issue on the affected system.

Our test site is: an.ericom.com
Account: u02/User123

Regards,
Ericom Support


 
James_Ericom
Top Contributor 66 posts
Joined: 02 Apr 2014

 


You are not Logged-in.
Log-in to post a message
Login  Register


Our Forums

Share this page