Ericom Forums
 
 
Support Center   |    Forums   |    Blog   |    Contact

Home / Community - Forums / PowerTerm WebConnect / Failed to connect using both HTTPS and WebSockets

Failed to connect using both HTTPS and WebSockets

2 posts, 1 answered

By Paul_jacobs » 02 Apr 2014

hi,

I am trying to use AccessNow( via Application Portal) through WebConnect, but when I click on an application it gives me the following error " "Failed to connect using both HTTPS and WebSockets"

I tried with different HTML5 compatible browsers, chrome, firefox, safari. All give me the same error.

I am using your Ericom Secure Gateway, and i followed the instructions in the manual to enable the use of the gateway and to "tell" the webconnect broker where the gateway is.

My testing is internal, so here is some information on what i am doing.
I am going to my test website on https://appsvr01//webconnect/AppPortal/index.asp

The secure gateway environment variable is set to 1
The gateway address variable is 192.168.15.4:443

Is there something that I am missing? 

 
Paul_jacobs
2 posts
Joined: 02 Apr 2014
By Adriel_Ericom » 02 Apr 2014

Hello Paul,

Thank you for your inquiry.

The address of the Ericom Secure Gateway (ESG) environment variable needs to be the same as the address you are using to access the website. 
In your particular case, if you choose to access the WebConnect website via the server's hostname of appsvr01, then the ESG enviroment variable needs to be "appsvr01:443"

This is also the same if you wish to access Webconnct's webpages via its IP address. Both the website's address and the ESG environment variable need to match. 

Additionally, when you decide to move your setup to production, the ESG's environment variable's address should reflect the external address of the machine the ESG is installed on. 

Please let me know if this resolves your issue.

Thank you. 

 
Adriel_Ericom
Ericom Employee 2 posts
Joined: 02 Apr 2014

 


You are not Logged-in.
Log-in to post a message
Login  Register


Our Forums

Share this page