Ericom Forums
 
 
Support Center   |    Forums   |    Blog   |    Contact

Home / Community - Forums / Ericom Connect / PowerTerm Interconnect - Win 10 via ssh to Linux server.

PowerTerm Interconnect - Win 10 via ssh to Linux server.

2 posts, 0 answered

By cityboy5705 » 14 Jun 2016

Hello Forum :

      I have been trying to set-up PowerTerm Interconnect for Windows on a Windows 10 laptop, using openssh, to connect to a CentOS 5.10 64-bit Linux server. I have previously set-up other users to login remotely to the server via ssh, but each of those users had Linux machines at home, so those worked right away. The user's account is set-up on the AllowUsers line in /etc/ssh/sshd_config, but when I try to login her account on PowerTerm, it returns "Unable to connect to host <user>@<IP address>".

       I tried going to an "Admin" Command Prompt, and doing "ssh -v <user>@<IP address>, and that logged her in, then immediately disconnected the session. Through trial and error, I figured out that was due to the TERM variable not being set. So, I executed a "set TERM=ansi", then retried the ssh -v command, and that allowed the account to login, and stay logged in. So that proves that ssh is working, on Win 10 no less, that the request is reaching the firewall, and through a specific firewall rule, is then sent to the Linux server. Unfortunately, this is just through the Win 10 command prompt, so it does not load any Function Keys, or have any of the other nice PowerTerm features.

    So what is different about the PowerTerm setup versus the command prompt? The ssh is configured for ssh-2, and I am using the default port 22, and I specified the id_rsa key, and the PowerTerm software converted that to the .epk extension.

      Any ideas would be most welcome. Thank-you.
      Bill Mohrhardt
      IT Manager, Ecological Fibers, Inc.
      bmohrhardt@ecofibers.com

 
cityboy5705
1 posts
Joined: 14 Jun 2016
By Cristian_Ericom » 07 Jul 2016

Hello Bill,

Thank you for taking the time to open this forum thread.
As far as I can see, the issue is reported in our ticketing system too and the ticket reference is CA0000024103.
Our colleagues are checking the issue and will reply to you once they have an update.

Kind regards,
Cristian

 
Cristian_Ericom
Top Contributor Ericom Employee 36 posts
Joined: 27 Jan 2015

 


You are not Logged-in.
Log-in to post a message
Login  Register


Our Forums

Share this page