PowerTerm Lite: system requirements from Ericom

System Requirements - PowerTerm Series Terminal Emulation


PowerTerm Lite (Windows edition)



Server Platforms
  • Windows Server 2008 / 2008 R2 / 2012 / 2012 R2 / 2016 / Terminal Services / RDS (physical or virtual). Both x86 (32-bit) and x64 (64-bit) are supported.

Client OS Platforms
  • Windows 7, 8, 10 - both x86 (32-bit) and x64 (64-bit) are supported
  • Connection to a host computer
  • 100 Mb of free space on your hard disk

  Close Window






Top