Ericom AccessNow system requirements from Ericom

System Requirements


Ericom AccessNow



Browsers - HTML5-capable browsers including, but not limited to:
  • Chrome 12 or higher
  • Safari 5 or higher
  • Firefox 6 or higher
  • IE10, IE 9 connecting through Ericom Secure Gateway
  • Microsoft Edge
  • Amazon Silk
Note: Some SSL VPNs may prevent some browsers from connecting, even if they are listed in the section above.

Clients - Supports any device running one of the browsers listed above, including:

  • Windows XP, Vista, Windows 7, Windows 8 and Windows 10. Both x86 (32-bit) and x64 (64-bit)
  • Windows RT (ARM)
  • Google Chrome OS (Chromebook and Chromebox)
  • Linux (Ubuntu, Red Hat, Novell SUSE, etc)
  • Mac OS X (Intel)
  • Apple iOS (iPad / iPad mini / iPhone / iPod)
  • Google Android
  • RIM Playbook and Blackberry 7 or newer
  • Amazon Kindle Fire HD
  • and any other device with an HTML5-capable browser



Server Platforms
  • Windows Server 2003 / 2008 / 2008(R2) / 2012 / 2012 R2 Terminal Services (physical or virtual). Both x86 (32-bit) and x64 (64-bit) are supported.
  • Windows XP, Vista,  Windows 7 and Windows 8  as remote desktops (physical or virtual). Both x86 (32-bit) and x64 (64-bit) are supported.
  • Server must have CPU with SSE2 instruction set support




  Close Window






Top