TOC -Previous

Chapter 6: Menu Reference

This chapter describes each of the PowerTerm menu bar options as shown below:

Use this chapter for reference only. See Chapter 4: Using PowerTerm for a detailed explanation of each step involved in using PowerTerm.

File Menu.

Edit Menu.

Terminal Menu.

Communication Menu.

Options Menu.

Script Menu.

Help Menu.

File Menu

The File menu provides options to create, save and restore a terminal setup file. You can also create an icon for your current PowerTerm settings, open keyboard and/or Power Pad settings and save them. You can also use this menu to set printing parameters, print, and to open a new instance of the PowerTerm window.

New Terminal Setup

Restores the default parameters including the terminal display colors.

If you have changed terminal parameters since the last save, PowerTerm displays a warning message asking whether or not to save the latest changes. The message points to the terminal settings file currently loaded (PTDEF.PTS is the default). Click No to cancel the latest changes and restore the default file.

Open Terminal Setup

Displays the Open File dialog box which enables you to select and open an existing setup (.PTS) file. For more information, see Step 5: Saving the Terminal Setup File.

Save Terminal Setup

Saves the currently open setup file. Both terminal setup and communication parameters are saved to the current setup (.PTS) file. For more information, see the section Step 5: Saving the Terminal Setup File.

Save Terminal Setup As

Opens the Save File As dialog box which enables you to save the current setup file under a different name.

Save As Icon

Opens the Save As Icon dialog box which enables you to create an icon for the current PowerTerm settings (.PTS file). This means that PowerTerm can be accessed from the Windows 95 Start menu, or by double-clicking the icon on your desktop. This enables you to start a session automatically with the desired parameters.

To avoid confusion, the name of the setup file should be changed. If you use the default name, PTDEF.PTS, these settings will become the default settings when PowerTerm is launched and no settings file has been specified.

Open Keyboard File

Opens the Open Keyboard File dialog box which enables you to open keyboard mapping settings that have previously been saved in a separate file.

Save Keyboard File

Opens the Save Keyboard File dialog box which enables you to save keyboard mapping settings in a separate file and open them at a later date.

Open Power Pad File

Opens the Open Power Pad File dialog box which enables you to open Power Pad settings that have previously been saved in a separate file.

Save Power Pad File

Opens the Save Power Pad File dialog box which enables you to save Power Pad settings in a separate file and open them at a later date.

Print Screen

Prints the contents of the work area, or the selected text.

Print Setup

Displays the Print Setup dialog box, which contains printing parameters. Displayed parameters change according to the printer you selected.

The Default Printer parameter enables you to send the output to the default printer selected under Windows. The Specific Printer parameter allows you to select one of the currently installed printers. For details about installing a new printer, consult your Windows documentation.

Start /Stop Auto Print

Prints all the data displayed in the work area. This option changes to Stop Printing once the Start Auto Print function is activated. Select Stop Printing to stop printing the data displayed in the work area.

Form Feed

Executes a form feed on the printer.

Line Feed

Executes a line feed on the printer.

New Terminal Window

Opens a new instance of the PowerTerm window. This enables you to run several sessions concurrently and simulate more than one terminal type. You can access a session by switching windows. After opening a new terminal window, you should define terminal and communication parameters before connecting to a host.

Exit

Enables you to exit PowerTerm. If you have changed the terminal settings, PowerTerm displays a warning message asking you if you want to update the terminal settings (.PTS) file. For more information, see Step 9: Exiting PowerTerm

Edit Menu

The Edit menu provides options to select, clear and reverse text in the PowerTerm window and delete the contents of the history buffer. The Edit menu also provides standard Windows editing commands (copy and paste), in addition to commands that enable you to copy data to a file and copy data automatically to the clipboard.

Select Screen

Selects the contents of the entire work area.

Clear Screen

Captures the entire PowerTerm screen and passes the data to the history buffer. An example of an application that issues clear screen commands is VMS Mail.

Reverse Screen

Changes the paragraph alignment. You can type from left to right or right to left, depending on the language you are using.

Clear History

Deletes the entire contents of the history or scrollback buffer. This command is only available when the history buffer is in use.

Copy

If the Automatic Copy option in the Edit menu is not active, use the Edit/Copy command to copy the marked text to the clipboard.

Paste

Pastes the clipboard contents into the work area.

Right-click (or select Edit/Paste) to send the host, data stored in the clipboard. This operation is equivalent to actually typing the contents of the clipboard on the host screen.

Copy to File

Copies selected information to a file. If no text is selected, the entire screen is written to the file.

Automatic Copy

Automatically copies selected information to the clipboard. When this option is active, all selected text is copied automatically to the clipboard and there is no need to select the Copy option.

Terminal Menu

The Terminal menu provides options to define and reset connection parameters, set the system to be online or offline and freeze or unfreeze the screen. The Terminal menu also enables you to select the system fonts you want to be displayed in the PowerTerm window, or use the default PowerTerm fonts.

Setup

Opens the Terminal Setup dialog box in which you can define settings for terminal emulation. This dialog box contains different tab pages which enable you to define all aspects of your terminal setup. For more information, see the section Step 3: Defining Settings for Terminal Emulation (Terminal Settings).

PowerTerm Fonts

Displays the default PowerTerm fonts defined in the PowerTerm window.

The default PowerTerm fonts are scalable, so that if the window shrinks, the fonts will shrink in relation to the size of the window.

System Fonts

Displays the system fonts you want to be displayed in the PowerTerm window.

System fonts remain the same size, no matter what the size of the window. When you select your own system fonts, you can only select fixed size fonts, meaning fonts that are nonscalable. System fonts enable you to select a different language.

Reset

Resets the VT terminal defaults. This command does not apply to PowerTerm. s exclusive terminal parameters (such as color).

Online

Sets the system to be online or offline.

Hold Screen

Stops communication and freezes the screen. To unfreeze the screen, reselect the command.

English

Displays a list of the available languages, below the commands on this menu, from which you can select a language for the PowerTerm interface, for example, English. This feature is optional.

Communication Menu

The Communication menu provides options to define and modify the communication (session) parameters, and to disconnect a communication session. The Communication menu also provides file transfer options. It enables you to set and clear Data Terminal Ready (DTR) and Ready to Send (RTS) signals. You can also select a modem from a list of existing modems.

Connect

Displays the Connect dialog box which enables you to define session parameters and connect to a host. For more information, see Step 6: Connecting to a Host.

Modify Connection

Displays the Connect dialog box which enables you to modify connection Parameters for COM type communication. For more information, see Step 6: Connecting to a Host.

Disconnect

Disconnects the communication session.

Modem Setup

Opens the Modem Setup dialog box which enables you to select a modem from a list of existing modems and initialization strings. It also enables you to add customized modem definitions and edit the initialization string provided.

Reset Communication

Resets the communication port for COM type communication.

File Transfer Setup

Displays the File Transfer Setup dialog box which enables you to define host and PC data types for file transfer.

Receive File

Receives a file from the host via Kermit, Zmodem, Ascii or Binary.

Send File

Sends a file to the host via Kermit, Zmodem, Ascii or Binary.

Utilities

Displays the following popup menu:

Dial

Enables you to dial a specific phone number for COM type communication.

Break

Sends a break for COM type communication. Equivalent to Ctrl + Break.

Set DTR

Sets DTR (Data Terminal Ready) signals.

Clear DTR

Clears DTR (Data Terminal Ready) signals.

Set RTS

Sets RTS (Ready to Send) signals.

Clear RTS

Clears RTS (Ready to Send) signals.

Options Menu

The Options menu enables you to display and edit the keyboard mapping and define the Power Pad display. The Options menu also enables you to store a session in a log file and provides options to show or hide PowerTerm window components.

Keyboard Map

Displays the Keyboard Mapping dialog box, which enables you to map your PC keys to host keys on the terminal keyboard. For more information, see the section Mapping the PC Keyboard.

Power Pad Setup

Displays the Power Pad Setup dialog box, which enables you to adjust the number of buttons contained in the Power Pad by specifying the number of rows and columns to be displayed. For more information, see the section Programming the Power Pad.

Start/Stop Trace

Stores the session in a log file. Raw data is stored in the Capture.log file, while formatted data with readable escape sequences is stored in the Trace.log file. This option changes to Stop Trace once the Start Trace option has been activated.

Input Trace

Enables you to view the contents of the Capture.log file on the PowerTerm desktop work area.

Hide Menu

Hides the menu bar. To restore the menu bar, select Restore Menu from the control menu box.

Hide Buttons

Hides the soft buttons. This option changes to Show Buttons when the soft buttons are hidden.

Hide Status Bar

Hides the status bar. This option changes to Show Status Bar when the status bar is hidden.

Hide Tool Bar

Hides the tool bar. This option changes to Show Tool Bar when the tool bar is hidden.

Show Power Pad

Displays the floating Power Pad.

Script Menu

The Script menu provides options to record, edit and run a script.

Run Script

Displays the Run Script dialog box which enables you to select and run a script. For more information, see the section Running PowerTerm Scripts in Chapter 5: Scripts.

Edit Script

Displays the Edit Script dialog box which enables you to select the script that you want to edit. The selected script is opened for editing in Notepad. For more information see the section Creating a Script and Editing a Script in Chapter 5: Scripts.

Script Command

Displays the Script Command dialog box which enables you to run individual script commands.

Start/Stop Script Recording

Writes a script automatically. After requesting Start Script Recording, the manual operations you perform in the emulation screen are recorded into a script file, until you choose the Stop Script Recording command. For more information, see the section Recording a Script in Chapter 5: Scripts.

Pause Script Recording

Pauses script recording. This enables you to exclude certain operations from recording. For more information, see the section Recording a Script in Chapter 5: Scripts.

Activate Recorded Script

Activates the script currently recorded in memory. The script is saved in memory while PowerTerm is active until it is saved to a specific file.

Save Recorded Script

Enables you to save a script from memory to a specific file. The script is saved in memory while PowerTerm is active until it is saved to a specific file.

Help Menu

The Help menu provides options for accessing the PowerTerm online help, Getting Started online help and product information.

Contents

Accesses the first page of the PowerTerm online help.

Getting Started

Accesses the first page of the PowerTerm Getting Started online help.

About PowerTerm

Displays product and contact information, in addition to memory and system resources.