Chapter 5: Menu Reference

This chapter describes each of the PowerTerm Pro menu bar options as shown below:

Use this chapter for reference only. See Using PowerTerm Pro for a detailed explanation of each step involved in using PowerTerm Pro.

File Menu

Edit Menu

View Menu

Terminal Menu

Communication Menu

Options Menu

Tools Menu

Script Menu

Window Menu

Help Menu

File Menu

The File menu provides options to create, save and restore a terminal setup file. You can also create an icon for your current PowerTerm Prosettings, open keyboard and/or Power Pad settings and save them. You can also use this menu to set printing parameters, print, and to open a new instance of the PowerTerm Pro window.

Default Terminal Setup

Restores the default parameters including the terminal display colors.

If you have changed terminal parameters since the last save, PowerTerm Pro displays a warning message asking whether or not to save the latest changes. The message points to the terminal settings file currently loaded (PTDEF.PTS is the default). Click No to cancel the latest changes and restore the default file.

Open

Displays the Open File dialog box which enables you to select and open an existing setup (.PTS) file. For more information, see Step 5: Saving the Terminal Setup File

Save

Saves the currently opened setup file. Both terminal setup and communication parameters are saved to the current setup (.PTS) file. For more information, see the section Step 5: Saving the Terminal Setup File

Save As

Opens the Save As dialog box which enables you to save the current setup file under a different name.

Save As Shortcut

Opens the Save As Icon dialog box which enables you to create an icon for the current PowerTerm Pro settings (.PTS file). This means that PowerTerm Pro can be accessed from the Windows 95 Start menu, or by double-clicking the icon on your desktop. This enables you to start a session automatically with the desired parameters.

To avoid confusion, the name of the setup file should be changed. If you use the default name, PTDEF.PTS, these settings will become the default settings when PowerTerm Pro is launched and no settings file has been specified.

Keyboard File

Opens the Open Keyboard File dialog box which enables you to open keyboard mapping settings that have previously been saved in a separate file. Opens the Save Keyboard File dialog box which enables you to save keyboard mapping settings in a separate file and open them at a later date.

Power Pad File

Opens the Open Power Pad File dialog box which enables you to open Power Pad settings that have previously been saved in a separate file. Opens the Save Power Pad File dialog box which enables you to save Power Pad settings in a separate file and open them at a later date.

Print Screen

Prints the contents of the work area, or the selected text.

Print Setup

Displays the Print Setup dialog box, which contains printing parameters. Displayed parameters change according to the printer you selected.

Start/Stop Auto Print

Prints all the data displayed in the work area. This option changes to Stop Printing once the Start Auto Print function is activated. Select Stop Printing to stop printing the data displayed in the work area.

Form Feed

Executes a form feed on the printer.

Line Feed

Executes a line feed on the printer.

Send Mail

Launches the default e-mail program and opens a new mail message with/without the desired attached setup file or screen capture.

Exit

Enables you to exit PowerTerm Pro. If you have changed the terminal settings, PowerTerm Pro displays a warning message asking you if you want to update the terminal settings (.PTS) file. For more information, see Step 9: Exiting PowerTerm Pro

Edit Menu

The Edit menu provides options to select, clear and reverse text in the PowerTerm Pro window and delete the contents of the history buffer. The Edit menu also provides standard Windows editing commands (copy and paste), in addition to commands that enable you to copy data to a file and copy data automatically to the clipboard.

Select Screen

Selects the contents of the entire work area.

Clear Screen

Captures the entire PowerTerm Pro screen and passes the data to the history buffer. An example of an application that issues clear screen commands is VMS Mail.

Clear History

Deletes the entire contents of the history or scrollback buffer. This command is only available when the history buffer is in use.

Copy

If the Automatic Copy option in the Edit menu is not active, use the Edit/Copy command to copy the marked text to the clipboard.

Paste

Pastes the clipboard contents into the work area.

Right-click (or select Edit/Paste) to send the host data stored in the clipboard. This operation is equivalent to actually typing the contents of the clipboard on the host screen.

Copy to File

Copies selected information to a file. If no text is selected, the entire screen is written to the file.

Automatic Copy

Automatically copies selected information to the clipboard. When this option is active, all selected text is copied automatically to the clipboard and there is no need to select the Copy option.

View Menu

The View menu provides options to view or hide the menu, toolbars, status bar and function buttons.

Menu

Determines if the menu bar will be displayed.

Toolbars

Determines which toolbars will be displayed.

Status Bar

Determines if the status bar will be displayed.

Emulation Screen

Displays the emulation screen.

Web Page

Displays the Ericom Homepage.

Script Editor

Launches the PowerBasic script editor.

View Menu

The View menu provides options to view or hide the menu, toolbars, status bar and function buttons.

Menu

Determines if the menu bar will be displayed.

Toolbars

Determine which toolbars will be displayed.

Status Bar

Determines if the status bar will be displayed.

Function Buttons

Displays/hides the function keys.

Emulation Screen

Displays the emulation screen.

Web Page

Displays the Ericom Homepage.

Script Editor

Launches the PowerBasic script editor.

Word

Launches Microsoft’s Word.

Excel

Launches Microsoft’s Excel.

Container

Stores an inserted object and can be modified with Paintbrush tools.

VB Magic

Runs the Sample VBA Project that demonstrates how you can utilize VBA in conjunction with PowerTerm Pro.

Terminal Menu

The Terminal menu provides options to define and reset connection parameters, set the system to be online or offline and freeze or unfreeze the screen. The Terminal menu also enables you to select the system fonts you want to be displayed in the PowerTerm Pro window, or use the default PowerTerm Pro fonts.

Setup

Opens the Terminal Setup dialog box in which you can define settings for terminal emulation. This dialog box contains different tab pages which enable you to define all aspects of your terminal setup. For more information, see the section Step 3: Defining Settings for Terminal Emulation (Terminal Settings)

Colors

Displays color parameters for data displayed in the work area.

PowerTerm Pro Fonts

Displays the default PowerTerm Pro fonts defined in the PowerTerm Pro window.

The default PowerTerm Pro fonts are scalable, so that if the window shrinks, the fonts will shrink in relation to the size of the window.

System Fonts

Displays the system fonts you want to be displayed in the PowerTerm Pro window.

System fonts remain the same size, no matter what the size of the window. When you select your own system fonts, you can only select fixed size fonts, meaning fonts that are nonscalable. System fonts enable you to select a different language.

Reset

Resets the VT terminal defaults. This command does not apply to PowerTerm Pro’s exclusive terminal parameters (such as color).

Online

Sets the system to be online or offline.

Hold Screen

Stops communication and freezes the screen. To unfreeze the screen, reselect the command.

Hotspots Setup

Creates a hotspot on the 3270/5250 emulation screen.

Language Selection

Selects a language for PowerTerm Pro’s interface.

Communication Menu

The Communication menu provides options to define and modify the communication (session) parameters, and to disconnect a communication session. The Communication menu also provides file transfer options. It enables you to set and clear Data Terminal Ready (DTR) and Ready to Send (RTS) signals. You can also select a modem from a list of existing modems.

Connect

Displays the Connect dialog box which enables you to define session parameters and connect to a host. For more information, see Step 6: Connecting to a Host

Receive File

Receives a file from the host via Kermit, Zmodem, ASCII or Binary.

Send File

Sends a file to the host via Kermit, Zmodem, ASCII or Binary.

Run FTP

Displays the File Transfer Setup dialog box which enables you to define host and PC data types for file transfer.

Options Menu

The Options menu enables you to display and edit the keyboard mapping and define the Power Pad display. The Options menu also enables you to store a session in a log file and provides options to show or hide PowerTerm Pro window components.

Keyboard Mapping

Displays the Keyboard Mapping dialog box, which enables you to map your PC keys to host keys on the terminal keyboard. For more information, see the section Mapping the PC Keyboard

Power Pad Setup

Displays the Power Pad Setup dialog box, which enables you to adjust the number of buttons contained in the Power Pad by specifying the number of rows and columns to be displayed. For more information, see the section Programming the Power Pad

Start/Stop Trace

Stores the session in a log file. Raw data is stored in the Capture.log file, while formatted data with readable escape sequences is stored in the Trace.log file. This option changes to Stop Trace once the Start Trace option has been activated.

Input Trace

Enables you to view the contents of the Capture.log file on the PowerTerm Pro desktop work area.

Show Power Pad

Displays the floating Power Pad.

Customize

Enables you to customize the menu bar and tool bar.

General Settings

Enables you to determine how you want to access ERICOM’s Web page, Script Editor, Microsoft’s Word and Excel.

Insert Object

Enables you to insert an object into the container and modify it with Paintbrush tools.

Tools Menu

The Tools menu provides options to create Macros or VBA scripts to be run in PowerTerm Pro. It also allows you to customize the menu bar and its options.

Macro

Creates Macros or VBA scripts to be run in PowerTerm Pro.

VBA Basic Editor

Opens the Visual Basic Editor.

Advanced

Opens a VBA project or runs the VBA Sample Project.

 

User Tools

Customizes the Tools menu with any particular application.

Script Menu

The Script menu provides options to record, edit and run a script.

Run Script

Displays the Run Script dialog box which enables you to select and run a script. For more information, see the section Running PowerTerm Pro Scripts

Edit Script

Displays the Edit Script dialog box which enables you to select the script that you want to edit. The selected script is opened for editing in Notepad. For more information see the section Creating a Script and Editing a Script

Script Command

Displays the Script Command dialog box which enables you to run individual script commands.

Start/Stop Script Recording

Writes a script automatically. After requesting Start Script Recording, the manual operations you perform in the emulation screen are recorded into a script file, until you choose the Stop Script Recording command. For more information, see the section Recording a Script

Pause Script Recording

Pauses the script recording temporarily.

Activate Recorded Script

Activates the script currently recorded in memory. The script is saved in memory while PowerTerm Pro is active until it is saved to a specific file.

Save Recorded Script

Enables you to save a script from memory to a specific file. The script is saved in memory while PowerTerm Pro is active until it is saved to a specific file.

Window Menu

The Window menu provides the user with an additional instance of PowerTerm Pro.

New Terminal Window

A new terminal window is opened displaying an additional instance of PowerTerm Pro.

Help Menu

The Help menu provides options for accessing the PowerTerm Pro online help, Getting Started online help and product information.

Help Topics

Opens PowerTerm Pro’s online help.

Tip of the Day

Displays the next Tip of the Day.

Ericom on the Web

Ericom resources on the World Wide Web that can be helpful to the PowerTerm Pro user.

About PowerTerm Pro

Displays product and contact information.