Chapter 3: Using PowerTerm Pro

This chapter provides step by step instructions for using PowerTerm Pro. It outlines the PowerTerm Pro workflow and provides a detailed explanation of each step.

PowerTerm Pro Workflow

Step 1: Starting PowerTerm Pro

Step 2: Setting up your Working Environment

Step 3: Defining Settings For Terminal Emulation

Step 4: Defining Modem and Communication Settings

Step 5: Saving the Terminal Setup File

Step 6: Connecting to a Host

Step 7: Working with the Host

Step 8: Ending a PowerTerm Pro Session

Step 9: Exiting PowerTerm Pro

PowerTerm Pro Workflow

The following diagram illustrates the PowerTerm Pro workflow.

If you are familiar with accessing remote terminals, you may want to follow the procedure outlined in A Quick Guide through PowerTerm Pro

This workflow provides a more detailed description of each step involved in using PowerTerm Pro. The remainder of this chapter is divided into the steps listed below:

Step 1: Starting PowerTerm Pro

When PowerTerm Pro is used for the first time, the PowerTerm Pro window is automatically displayed together with the Connect dialog box. After the connection parameters have been defined, the Connect dialog box is no longer automatically displayed when you open PowerTerm Pro. Refer to Connecting to host for more information on defining connection parameters.

Starting PowerTerm Pro using a Setup File

PowerTerm Pro can be started using a default or customized setup file. A default setup file is used to connect to a single host, while a customized setup file is used for different terminal emulations. A setup file contains both communication session parameters and terminal setup parameters.

The setup file is in text format and can be edited using a text editor.

Starting PowerTerm Pro with the Default Setup File

The PowerTerm Pro default setup file is called PTDEF.PTS. When you open PowerTerm Pro, it automatically uses this file to start the system.

Auto Connect

The Auto Connect option enables you to automatically connect to a specific terminal using the parameters in the default setup (PTDEF.PTS) file.

To access the Auto Connect option, select the Setup option from the Terminal menu. The Terminal Setup dialog box is displayed. Click the Preferences tab and select the Auto Connect option.

For more information about this option, see the Preferences Properties .

Starting PowerTerm Pro with a Customized Setup File

PowerTerm Pro enables you to run a customized setup file from startup by using a command or creating a Windows shortcut. This accesses PowerTerm Pro and the specific setup file. You can use this option to start PowerTerm Pro with predefined communication and terminal setup parameters for a specific host.

Before you create a shortcut to a setup file, you need to first create and save the setup file in PowerTerm Pro. For details about how to create and save a setup file, see Steps 3: Defining settings for terminal emulation

You can also select and open a terminal setup file during a PowerTerm Pro session. For more information, see Step 6: Connecting to a Host.

The following procedure describes one way to create a shortcut. Consult your Windows 95 documentation for a description of other available options.

1) Right-click the Start button on your Windows 95 desktop.

3) Select the Programs file folder.

PowerTerm Pro recognizes Windows 95 file naming conventions, including spaces in a file name. If you have a setup file with a space in the name, for example Setup 1.PTS, PowerTerm Pro ignores the space and looks directly for the .PTS extension.

If you are starting PowerTerm Pro for the first time, the Connect dialog box is displayed.

If you have previously created an icon on your desktop for your PowerTerm Pro settings, you can customize the PowerTerm Pro setup file by right-clicking the icon and continue from step 5 above. For more information, see Step 5: Saving the Terminal Setup File.

Using a Setup File During a PowerTerm Pro Session

You can also open a terminal setup file (.PTS) while using PowerTerm Pro to run a session using predefined terminal setup and communication parameters. PowerTerm Pro provides two options to open a setup file:

Starting PowerTerm Pro using a Script

You can also launch PowerTerm Pro and run a script immediately upon launching. Scripts are created with Power Script Language (PSL) and enable you to automate tasks. For example, you can use a script to automatically connect to a specific host. For more information, see the section Running a Script upon Startup

Step 2: Setting Up your Working Environment

This section provides a description of the basic operations that may be performed to set up and optimize the PowerTerm Pro working environment for your usage.

You can also customize the PowerTerm Pro window to show or hide window components and change the display of the window. These options are all described in the section Manipulating Desktop Components

PowerTerm Pro enables you to emulate a host keyboard by assigning (mapping) PC keys to host keys. It furthermore provides two features, the Power Pad and soft buttons, which enable you to automate commands.

PowerTerm Pro also enables you to save your keyboard and/or Power Pad settings in separate files and open them at a later date.

Mapping the PC Keyboard

Saving and Opening Keyboard Mapping Settings

Programming the Power Pad

Saving and Opening your Power Pad Settings

Programming Soft Buttons

Selecting Fonts

Mapping the PC Keyboard

PowerTerm Pro enables you to map PC keys to host keys in order to emulate the host terminal keyboard. Keyboard mapping definitions are stored in a file with the same name as the current terminal setup file, with the extension .PTK. For example, the default keyboard mapping definitions are stored in a file called PTDEF.PTK.

PowerTerm Pro enables you to move the functionality of a mapped PC key to another PC key in two ways:

Changes made to the keyboard mapping will not affect the Power Pad or soft buttons.

1) From the Options menu, select the Keyboard Map option. The Keyboard Mapping dialog box is displayed:

2) Slide the mouse pointer over the different keys. The bottom line of the dialog box shows you the corresponding PC and terminal keys. For example, if you point to the "t" key of the VT Keyboard, you see that the corresponding PC key is "T".

In the Keyboard Mapping dialog box, drag a key from the upper terminal keyboard to a PC key on the lower keyboard.

F To map a PC key from a host key:

In the Keyboard Mapping dialog box, drag a key from the upper terminal keyboard to a PC key on the lower keyboard.

or

Click the <Shift> or <Control> keys on the terminal keyboard to display additional key functions. For example, if you click the <Shift> key, the alphabet keys on the terminal keyboard are displayed in upper case. You can then map (drag) these keys to your PC keyboard keys.

1) From the Options menu, select the Keyboard Map option. The Keyboard Mapping dialog box is displayed.

3) Enter the script command description and click OK. The PC key has now been assigned a script command.

Click the <Alt>, <Ctrl> or <Shift> key (or any combination) on your PC keyboard.

You can map keys by following the procedure described above.

To view the mapped key, click the required <Alt>, <Ctrl> or <Shift> key (or combination of these keys), and then click the mapped key.

In the Keyboard Mapping dialog box, drag to the wastebasket the PC key definition that you want to cancel. This restores the default function of the PC key.

PowerTerm Pro enables you to transfer the function of a mapped PC key to another PC key. For example, you can drag the F6 key on the PC keyboard to the spacebar giving the F6 function to the spacebar.

In the Keyboard Mapping dialog box, drag the required PC key onto the PC key that it will replace. This cancels the function of the original PC key. To cancel the replacement, drag the replaced key back to its original position.

or

PowerTerm Pro enables you to copy the function of one PC key to another PC key.

In the Keyboard Mapping dialog box, hold the Control key while you drag the PC key, whose function you want to copy, to the required PC key. Both keys now have the same function.

or

In the Keyboard Mapping dialog box, click the Defaults button.

Saving and Opening Keyboard Mapping Settings

PowerTerm Pro enables you to save keyboard mapping settings in separate files and open them at a later date.

1) From the File menu, select Open Keyboard File. The Open Keyboard File dialog box is displayed:

2) Select the directory in which the keyboard file is saved.

3) Select the required keyboard file from the files list. The file name is highlighted.

4) Click Open. Parameters defined in the selected keyboard file are now applied to the current session.

Programming the Power Pad

The Power Pad is a floating key pad that contains buttons which can be programmed to execute customized PowerTerm Pro scripts. You can also change their names and adjust the number of buttons displayed in the Power Pad.

The Power Pad enables you to customize PowerTerm Pro, in addition to keyboard mapping and the soft buttons. Changes made to the Power Pad will not affect keyboard mapping or soft buttons.

Power Pad buttons are named by default F1, F2, F3, and so on with a few default function names, such as Clear, Enter and Insert. Left-clicking on the F1 button is equivalent to sending F1 to the host.

1) From the Options menu, select Show Power Pad. The Power Pad is displayed:

2) Right-click on the Power Pad button that you want to program. The Power Pad Button dialog box is displayed:

3) Enter the new Power Pad button description in the Button Description field.

4) Enter the script command (or more than one script command separated by semicolons) in the Script Command field to be run by this button.

For example, exec f5 (see above).

Click OK. The Power Pad button is now displayed with its new name. Clicking on the Power Pad button with the left mouse button will execute the newly defined script commands. For example, sending <F13> to the host. For more information, see the section Creating a Script

You can display a maximum of 10 rows and 10 columns in the Power Pad. The default number of buttons is 9 rows and 4 columns.

1) From the Options menu, select Power Pad Setup. The Power Pad Setup dialog box is displayed:

2) Click on the dropdown box to select the number of rows or columns that you want the Power Pad to contain.

Saving and Opening Power Pad Settings

PowerTerm Pro enables you to save your Power Pad settings in separate files and open them at a later date.

1) From the File menu, select Open Power Pad File. The Open Power Pad File dialog box is displayed:

2) Select the directory in which the Power Pad file is saved.

3) Select the required Power Pad file from the files list.

4) Click Open. Parameters defined in the selected Power Pad file are now applied to the current session.

Programming Soft Buttons

Along the bottom of the PowerTerm Pro window are twelve programmable buttons. These are called soft buttons, shown below:

You can rename the soft buttons and program them to execute customized scripts. The soft button parameters are saved automatically in the terminal setup file.

Soft buttons are named by default from F1 to F12. Left clicking on the F1 button is equivalent to sending F1 to the host.

Soft buttons enable you to customize PowerTerm Pro, in addition to keyboard mapping and the Power Pad Pro. Changes made to the soft buttons will not affect keyboard mapping or the Power Pad.

1) Click with the right mouse button on the soft button that you want to program. The Function Button dialog box is displayed:

2) Enter the new Power Pad button description in the Button Description field.

3) Enter the script command (or more than one script command separated by semicolons) to be run by this button.

For example, exec f5 (see above).

Click OK. The soft button is now displayed with its new name. Clicking on the soft button with the left mouse button will execute the newly defined script command. For more information, see the section Creating a Script

Selecting Fonts

PowerTerm Pro enables you to select the system fonts you displayed in the PowerTerm Pro window or use the default PowerTerm Pro fonts.

The default PowerTerm Pro fonts are scalable, so that if the window is made smaller, the font size is reduced in relation to the size of the window.

System fonts remain the same size, no matter what the size of the window. When you select your own system fonts, you may only select fixed size fonts, meaning fonts that are not scaleable. System fonts enable you to select a different language.

    • To select PowerTerm Pro fonts:

From the Terminal menu, select the PowerTerm Pro Fonts option. The PowerTerm Pro window will now display PowerTerm Pro fonts.

    • To select system fonts:
      • From the Terminal menu, select the System Fonts option. The Font dialog box is displayed:

2) Define the system font parameters by selecting the font, style and size required.

    • Click OK. The PowerTerm Pro window will now display the system font selected.