Chapter 2: The PowerTerm Pro Window

This chapter provides an overview of the PowerTerm Pro window and its components. The PowerTerm Pro window contains menu and toolbar options which provide access to most PowerTerm Pro functions. The remainder of PowerTerm Pro functions can be accessed by clicking the right mouse button on the relevant PowerTerm Pro object.

The most important feature of the PowerTerm Pro window is its work area, which emulates a host terminal screen by displaying data entered on your terminal, and data received from the host. This chapter also includes a section describing how to select text in PowerTerm Pro.

The PowerTerm Pro Window

Menu Bar

PowerTerm Pro Toolbars

Hot Keys

Manipulating Desktop Components

Selecting Text

The PowerTerm Pro Window

Control Menu Box: Provides standard Windows commands and enables you to redisplay the menu bar.

Title Bar: Displays the application name. During a communication session, the session type and the host name is displayed next to the application name. For example, (A) TELNET (126.0.0.200): PowerTerm Pro.

Menu Bar: Contains dropdown menus which enable the user to perform most PowerTerm Pro operations. See Menu Bar for further information.

Standard Toolbar: Contains tools which can be used as shortcuts to access frequently used menu commands. See Toolbar for further information.

Work Area:Displays the data entered on the PC terminal or received from the host. During an emulation session, this work area emulates a terminal display.

For IBM terminal types, the work area is displayed in black.

History Scroll Bar: Enables you to scroll up and down through the PowerTerm Pro window to view previously displayed data. This is available for non-IBM emulations only. The History Scroll Bar is displayed by default. If the History Scroll Bar is not displayed, select Setup Command from the Terminal menu to display it. Click the Display tab and select the History Scroll Bar checkbox.

Emulator Type: Displays the current terminal emulation type selected from the Emulation tab in the Terminal Setup dialog box.

Cursor Position Counter: Displays the current line and column position of the text cursor in the work area.

Autowrap Character Indicator: Indicates whether the keyboard is in autowrap character mode.

Caps: Indicates whether the keyboard is in caps lock mode.

Hold: Indicates whether the screen is in hold or frozen mode.

Status Indicator - On Line, Off Line, Printer, Auto Prt: When communication is established, the status indicator reads On Line.
When data is transmitted with a printing request to the slave printer, the indicator reads Printer. The color of the indicator is the same as when PowerTerm Pro is in On Line mode. For example, if the system was On Line when the printing request arrived, the printer will appear in red. When the terminal is in automatic printing mode, the data is sent to the screen and printer, and the indicator reads Auto Prt.

Soft Button Area: Contains a series of buttons that you can program to execute specific script commands. See the section Programming Soft Buttons for further information.

Script/Message Display Area: Displays system messages, or a script sequence as you type it in the work area.

Minimize button: Closes the window, but not PowerTerm Pro. Click this button to reopen the PowerTerm Pro window. You can use this button to make room on your Windows desktop.

Maximize button: Enlarges a window so that it fills the entire screen. After you maximize a window, the maximize button is replaced with the restore button . This button is used to restore the window to its previous size.

Window Border and Corners: Changes the size of the window. As you change the window size, the characters that appear in the work area are scaled up or down, so that all the information always remains in view.

Menu Bar

The PowerTerm Pro menu bar, shown below, displays the main PowerTerm Pro functions in dropdown menus.

The following is a brief description of each PowerTerm Pro menu and the functions that it can perform. For a description of each menu option, see Menu Reference

File Menu: Provides options to create, save and restore a terminal setup file. You can also use this menu to set printing parameters, print the screen and open a new instance of the PowerTerm Pro window. The File menu also enables you to save your keyboard and Power Pad settings, and open them at a later date.

Edit Menu: Provides options to select, clear and reverse text in the PowerTerm Pro window. You can delete the contents of the history buffer. The Edit menu also provides standard Windows editing commands (copy and paste), in addition to commands that enable you to copy data to file and copy data automatically to the Clipboard.

Terminal Menu: Provides options to define terminal parameters and reset connection parameters (terminal and communication parameters), set the system to be online or offline, and freeze or unfreeze the screen. You can also select the fonts to be displayed in the PowerTerm Pro window.

View Menu: Provides options to view or hide the menu, toolbars, status bar, script editor and function buttons.

Communication Menu: Provides options to define and modify the communication (session) parameters, and to disconnect a PowerTerm Pro session. The Communication menu also provides file transfer options. You can select a modem, add customized modem definitions and edit the initialization string.

Options Menu: Provides options to display and edit the keyboard mapping, and define the Power Pad display. The Options menu also enables you to capture session data in a log file for debugging purposes. It provides options to hide PowerTerm Pro window components.

Tools Menu: Provides the user with user tools.

Script Menu: Provides options to record, edit and run a script. The Script menu also enables you to open and save scripts.

Window Menu: Provides the user with another instance of PowerTerm Pro.

Help Menu: Provides options for accessing the PowerTerm Pro online help and product information.

Menu Conventions

The following Windows conventions are used in PowerTerm Pro menus:

Grayed text: Indicates that the menu option is inactive or unavailable.

An Ellipsis (…): Indicates that more information is required to complete the command.

Working with Menus and Commands

You can select menus and commands by:

1) Point to the name of the menu on the menu bar.

2) Click the mouse button. The menu drops down.

3) Slide the mouse over the command that you want to select and click.

After clicking the name of a menu or the menu bar, you can drag the mouse to the right, left, up or down, to move to other options.

1) Press the <Alt> key to access the menu bar. The far left menu is highlighted.

2) Use the direction (arrow) keys to move the highlighting bar to select a menu.

3) Press the down arrow to open the menu.

4) Use the arrow to highlight the command that you want and press the <Enter> key.

Menus, menu items and commands have an underline character. You can select a menu by holding down the <Alt> key, and then type the underlined letter. For example, you can open the File menu by holding down the <Alt> key and type the letter <F>. Once a menu is open, you can select an item by just typing its underline character.

PowerTerm Pro Toolbars

The PowerTerm Pro toolbars include:

Standard Toolbar

The PowerTerm Pro Standard Toolbar, shown below, contains tools (buttons) which provide shortcuts to frequently used menu options.

For IBM emulation types, the toolbar consists of fewer options.

The following is a brief description of the tools in the PowerTerm Pro toolbar:

Hold Screen/Release Hold: Freezes and unfreezes the PowerTerm Pro window. Equivalent to Terminal/Hold Screen.

New Terminal Window: Opens a new instance of the PowerTerm Pro window. This option enables you to conduct several sessions concurrently. Equivalent to File/New Terminal Setup.

Connect/Disconnect: Enables you to define session communication parameters and connect to the host computer. Equivalent to Communication/Connect.

Copy To Clipboard: Copies the selected data displayed in the PowerTerm Pro work area to the Clipboard. Equivalent to Edit/Copy.

Paste From Clipboard: Pastes data from the Clipboard to the host application. Equivalent to Edit/Paste.

Print: Prints selected text or the entire contents of the work area. Equivalent to File/Print Screen.

Start/Stop Auto Print: Prints incoming data as it is displayed on the screen. Equivalent to File/Start Auto Print.

Dial: Enables you to dial a specific phone number for COM type communication. Equivalent to Communication/Utilities/Dial.

Start/Stop Script Recording: Records manual operations that you perform in script form. Equivalent to Script/Start Script Recording.

Change To 80 Lines: Specifies an 80 line display for the PowerTerm Pro work area. Equivalent to Terminal/Setup/Display.

Change To 132 Lines: Specifies a 132 line display for the PowerTerm Pro work area. Equivalent to Terminal/Setup/Display.

Terminal Setup: Displays the Terminal Setup dialog box in which you can define terminal setup parameters. Equivalent to Terminal/Setup.

Color Configuration: Displays the Colors dialog box in which you can define the color of data in the work area. Equivalent to Terminal/Colors.

Keyboard Mapping: Opens the Keyboard Mapping Dialog box in which you can map PC keys to host keys. Equivalent to Options/Keyboard Map.

Show/Hide Power Pad: Displays the Power Pad. Equivalent to Options/Show Power Pad.

  About Pro: Displays product and contact information. Equivalent to Help/About PowerTerm Pro.

Web Toolbar

The PowerTerm Pro Web Toolbar, shown below, contains buttons which allows one to navigate the web.

Back button

Forward button

Stop button

Refresh button

Ericom home page

The Address bar is a space to type and display the address for a Web page.

  If your PowerTerm Pro internal Web browser toolbar is disabled, see General Settings

External Applications Plus Toolbar

The External Applications Plus toolbar enables the PowerTerm Pro user to work conveniently on his favorite programs from within the emulation screen. Toggle back and forth to the desired program by clicking the desired application’s button.

Emulation screen button

Web browser button

Script editor button

Word processor button

Excel spreadsheet button

Container button

VB Magic button

  The Container incorporates OLE technology which enables you to create objects with one application and then link or embed them in a second application. Embedded objects retain their original format and links to the application that created them.

Script Editor Toolbar

The Script Editor toolbar enables the PowerTerm Pro user to work conveniently in the script editor within the emulation screen. This versatile editor enables one to undo a mistake, redo a dismissed action, find a particular string of characters, and toggle back and forth to different bookmarks.

Undo an unwanted action.

Redo the action that you previously erased.

Searches for the desired string in the text.

Searches for the next occurrence of the desired string in the text.

Toggle bookmark.

Locates the next bookmark.

Locates the previous bookmark.

Clears all bookmarks.

Place your mouse cursor over a tool. A box appears displaying the tool's description.

Hot Keys

Hot keys are keyboard keys that you can press instead of choosing menu commands. These hot keys refer to your standard PC keyboard keys, before they are mapped to terminal keys. Once hot keys are mapped, they lose their original function and reflect the newly mapped terminal key. For example, if you map <Alt F4> to the <Backspace> key on the terminal keyboard, it performs the function of a <Backspace> key.

The following table lists the default PowerTerm Pro hot keys:

Alt F4

Exit.

Alt F6

Open new terminal window.

Alt F9

Activate script.

Ctrl + Alt F9

Start/stop recording script.

Alt F10

Select screen.

Alt F11

Clear screen.

Alt F12

Reverse screen.

Scroll Lock

Hold screen.

Pause

Change the cursor shape.

Ctrl Up Arrow

Scroll up one line.

Ctrl Down Arrow

Scroll down one line.

Ctrl Home

Scroll to beginning of the history buffer.

Ctrl End

Scroll to end of the history buffer.

Ctrl Page Up

Scroll up one page.

Ctrl Page Down

Scroll down one page.

Shift + Ctrl + X

Switches focus to session X, where X is the session letter (A…Z) displayed in the PowerTerm Pro window title bar.

Ctrl + Spacebar

Switch between sessions to access the next active session.

Manipulating Desktop Components

PowerTerm Pro enables you to customize the PowerTerm Pro window by hiding or displaying desktop components and changing the display colors for different text attributes.

On the View menu, click Menu. This removes the menu bar altogether.

To restore the menu bar, click the control-menu box, then click Restore Menu.

On the View menu, click Buttons. The menu option becomes unchecked. This removes the soft buttons altogether.

You can click it to redisplay the soft buttons bar. The menu option is indicated with a checkmark.

On the View menu, click Status Bar. The menu option becomes unchecked. This removes the status bar altogether.

You can click it to redisplay the status bar. The menu option is indicated with a checkmark.

On the View menu, click Toolbars.

Select Standard. The menu option becomes unchecked. This removes the toolbar altogether.

You can click it to redisplay the tool bar. The menu option is indicated with a checkmark.

From the View menu, select the Web Page option or click the Web Page icon.

On the Options menu, click Show Power Pad to display the Power Pad.

You can click it again and hide the Power Pad.

This option is only available for non-IBM emulations.

2) Click the Display tab.

3) Click the History Scroll Bar checkbox to select it. Click again to clear the selection.

4) Click OK to close the Terminal Setup dialog box.

The PowerTerm Pro window is displayed again with or without the history scroll bar as selected.

3) In the Text area, click the color that you want to apply to the text (foreground) of the display.

4) In the Background area, click the color that will apply to the background of the text.

In non-IBM emulations, the Select Attribute of the entire screen is generally Normal. The color for the Normal attribute determines the color of the entire work area.

The box above the Select Attribute parameter shows the result of your selections.

5) Click OK to close the Terminal Setup dialog box and display the PowerTerm Pro window in the selected colors.

If data is transmitted with the Underline attribute, you can disable the underline by clearing this parameter. You can select the parameter to enable underlined characters.

If data is transmitted with the Blink attribute, you can disable blinking by clearing this parameter. You can select the parameter to enable blinking.

Select this parameter to disable the host color definitions and to work with your own (PC) color scheme.

Selecting Text

The following are descriptions of specific text selection techniques that you may find useful in different emulations.

In the work area, you can select text using the mouse. Clicking a word selects the word. <Ctrl> + clicking a word selects the word and any punctuation marks or other symbols, up to the first space that follows them.

If the Automatic Copy option in the Edit menu is active (default), selecting text also copies the selection to the Clipboard.

A block is any section of the work area.

In VT, point to one corner of the block, hold down the <Ctrl> key and drag the mouse to the opposite corner of the block.

In 3270 and 5250, point to a line and drag the mouse to the last line you want to include in the selection.

Point to a line, hold down the <Shift> key and drag the mouse to the last line you want to include in the selection. Then, release both the <Shift> key and the mouse button.

VT emulation: Point to the first character that you want to include in the selection. Drag the mouse to the last character that you want to include in the selection and release the mouse button.

5250 and 3270 emulations: Hold down the <Ctrl> key and drag.

From the Edit menu, choosethe Select Screen option.

Double-clicking a word (VT emulations only) sends the word to the host followed by an <Enter> signal. Use this feature to select a menu entry. For example, if the emulation screen displays the menu of an application residing on the host, just click a menu entry to activate the program that the menu entry represents.

In 3270 emulations, any double click on the screen is equivalent to touching the screen with a light pen.