PowerTerm InterConnect system requirements from ericom

System Requirements


PowerTerm InterConnect

(Windows edition)

Listed below are the minimum system requirements that are needed to run your PowerTerm software to its full potential.

Please contact us with any questions or queries regarding these hardware requirements.

  • Windows® XP and higher*. Both 32-bit and 64-bit OS are supported.
  • 386 data processor or higher.
  • Connection to a host computer.
  • 25 Mb of free space on your hard disk.
  • IE version 6 or higher.
  • MS RDP control installed on your PC.

*Windows 2003 / 2008 / 2008 R2 / 2012 / 2012 R2 are compatible with PowerTerm InterConnect version 10.1 and higher RTL edition. Both 32-bit and 64-bit OS are supported.

For FIPS support please mail supportUSA@ericom.com


  Close Window






Top