Application Portal on Windows Server 2008 64bit -
  FAQs 
  < BACK TO QUESTIONS 
question
Application Portal displays a red X instead of the user`s published application. How do I fix this?
  
answer

Application Portal may display a red X or missing picture icon instead of the user`s published applications, as a result of one of the following reasons:

A. Using 64bit server without enabling 32bit applications on the IIS.

B. Missing DLL file\s in WebConnect`s ComPortal folder (Please make sure that both of the following files are located in the ComPortal folder: ComPortal.dll,openssl.dll ).

C. Permissions issue (We would recommend making sure that the server`s Internet User has full access to WebConnect`s ComPortal folder.

D. Using Windows 2008 with TS Gateway or RPC over HTTP Proxy.In case that this is the root of the problem, there are two alternative solusions:

Solution 1 - if TS Gateway functionality of Windows 2008 64 bit is not needed:

I. Open Server Manager > Features, remove RPC over HTTP Proxy (it will remove also TS Gateway).
II. Go to IIS Manager, ApplicationPools, select DefaultAppPool > Advanced Settings > Enable 32-bit Applications = True
III. Restart IIS 

Solution 2 - if TS Gateway functionality of Windows 2008 64 bit Terminal Server is needed:

I. Open c:\windows\system32\inetsrv\config\applicationHost.config file, in the globalModules section find RpcProxy.dll, add preCondition="bitness64" :
<add name="PasswordExpiryModule" image="C:\Windows\system32\RpcProxy\RpcProxy.dll" preCondition="bitness64" />
II. Open Internet Information Services (IIS) Manager. Create new Application Pool (For example: "32bit-pool")
III. Open Advanced Settings for new Application Pool ("32bit-pool").
IV. Set  Enable 32-bit Applications = True
V. Go to Default WebSites > WebConnect, Convert this Virtual Directory To Application, choose new Application Pool ("32bit-pool").
VI. Do the same for WebConnect5.x Virtual Directory
VII.  Restart IIS




Top